Android XShell idea docker安装 npm random gwt arduino jScrollPane vue框架 android实战项目 java商城源码 jq选择第一个子元素 hadoop入门书籍 sublime分屏快捷键 git下载项目 python高级教程 python创建对象 python写文件 python基础知识 python写入txt文件 javapackage java的环境配置 java学习文档 java文件重命名 java终止线程 java获取文件 linux安装教程 saminside HTML5从入门到精通 ps去白底 彻底卸载mysql pr时间轴 磁芯大战 混凝土配合比计算软件 nginx启动命令 字符串分割 c4d序列号 数据挖掘案例 大话5g
当前位置: 首页 > 学习教程  > 编程语言

如何降低Python解析器环境的依赖包版本

2020/9/19 14:40:35 文章标签:

前言

在进行python编程的时候, 经常会出现代码包的版本不匹配的问题, 比如 tensorflow 编程的时候, 出现 找不到一些变量的问题, 原则上如果能力和精力都足够的话, 确实可以直接修改代码, 但从我个人角度来讲, 开发使用的人员 没必要去浪费这个时间, 因为各类平台多种多言,版本也是各不相同, 既然是基于他人平台开发, 那么在平台问题上浪费的时间, 不应该由使用者去承担。介绍两种办法用于降低python 代码包 版本。

降低python代码 包的版本

  • 第一种办法最为简单粗暴, 直接安装对应的python 包所需要的版本的 python版本, 也就是说 系统中,同时去安装多个python版本, 而且也是最为简单且节省精力的办法 。(ps: 因为各个python的发行版本, 其提供的相对应的各个package包在版本也是相对应的, 这个特性确实是其他编程语言所没有的,该功能相对来说,对开发者来说, 能节省很多不必要浪费的时间。
  • 第二种办法 是针对不想重新配置python 环境和代码包的伙伴, 并且在使用pip安装的时候,找不到对应的版本:
    pip install tensorflow== , 的时候,可以按照以下步骤进行操作。
    • 进入https://pypi.org 网址, 搜索对应的代码包,找到 download history的入口。
      在这里插入图片描述
    • 找到以下版本列表,下载whl安装包文件, 然后在python 中, 先安装 wheel 工具,再利用 pip 进行安装。
      注意:要先读懂以下列表信息,再下载安装, 避免走弯路。
文件名版本
tensorflow-2.3.0-cp37-cp37m-manylinux2010_x86_64.whlmanylinux2010_x86_64表示在linux系统的文件cp35表示适用python3.5版本
==tensorflow-2.3.0-cp37-cp37m-win_amd64.whl (342.5 MB)==中win_arm64表示在windows系统的文件cp37表示适用python3.7版本,注意有些版本只支持较低版本的python解析器,这点在下载的时候要特别注意,这个时候,就要先把python版本降低了,否则会出现平台不匹配的消息。


本文链接: http://www.dtmao.cc/news_show_200136.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?