R语言 Jenkins docker安装 xml sockets highcharts redis常用语句 path webforms ios5 Uploadify jquery遍历元素 jquery解析json数据 oracle显示所有数据库 linux查看mysql进程 linux超级用户 js空格符 tomcat调优和jvm调优 安装mysql python异常 python支持中文 java基础教程 java中的tostring java求和 java怎么连接数据库 学习java基础 java的random 思源黑体cn 魔兽七个人 战斗的召唤 cubase下载 小程序开发工具下载 现代操作系统 编程电子书 linux系统下载 炫舞爱的惊喜 冰冠堡垒单刷路线 ps怎么旋转图层 js绑定事件的方法 flash引导层
当前位置: 首页 > 学习教程  > 编程语言

踩坑指南!pytorch1.0.1安装!又是猛男落泪的一天!

2020/10/8 20:14:34 文章标签:

git的一个源码在train的时候要求pytorch的版本降到1.3.0以下。第一次试了1.2.0,下载太慢了,加源后源中找不到1.2.0,太拉垮了,看网上好多人都在用1.0.1,于是就试了一下这个。 添加源: conda config --add …

git的一个源码在train的时候要求pytorch的版本降到1.3.0以下。第一次试了1.2.0,下载太慢了,加源后源中找不到1.2.0,太拉垮了,看网上好多人都在用1.0.1,于是就试了一下这个。

添加源:

conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/
conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/main/
conda config --set show_channel_urls yes
conda config --add channels https://mirrors.tuna.tsinghua.edu.cn/anaconda/cloud/pytorch/

安装命令:

conda install pytorch==1.0.1 torchvision==0.2.2 cudatoolkit=10.2 

装好后检查:

python

>>>import torch

无报错则证明安装成功。但是我出现错误:

from torch._C
import * ImportError: DLL load failed: 找不到指定的程序。

太鸡肋啊啊啊啊,这个就是版本不匹配的问题,但是是哪个不匹配我真的花了很大的时间。
可能的解决方法:

更改python版本,pytorch1.0.1自带的python版本为3.6.2,直接conda install python就可安装到对应版本。
更改numpy版本,看到有网有说更改为: conda install numpy=1.17

检查:

print(torch.__version__)
1.0.1

但是我现在cuda貌似和pytorch版本不匹配,等我再研究一下。


本文链接: http://www.dtmao.cc/news_show_250225.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?