大数据平台 vim复制 JS symfony deployment yii ldap wso2 progressjs vue路由 bootstrap框架 bootstrap日历插件 python的array python语言 python变量定义 python函数参数 python获取时间戳 java正则 java基础语言 javaforeach java如何连接mysql java初级入门教程 java集合转数组 linuxls命令 战地女记者 jb51 java程序设计基础 html特殊符号 flash制作工具 笔记本测试软件 电脑cmd命令大全 流程图制作工具 拼多多商家下载 apihook appdata是什么文件夹 0000008e 复仇之矛天赋 dnf风神加点 抽出滤镜下载 华为工具箱
当前位置: 首页 > 学习教程  > 编程语言

静态路由全网互通实验

2020/10/8 20:31:32 文章标签:

[TOC](静态路由全网互通) 一级目录 1.路由协议: 静态路由-管理员手工配置路由 局域网内-IGP(内部网关路由协议) 2.选取最优路由时的标准 1.子网掩码长度最长的最优先匹配 2.选取路由协议中最优先级最小的最优先匹配 DIRECT:0…

@[TOC](静态路由全网互通)

一级目录

1.路由协议: 静态路由-管理员手工配置路由

局域网内-IGP(内部网关路由协议)

2.选取最优路由时的标准

1.子网掩码长度最长的最优先匹配
2.选取路由协议中最优先级最小的最优先匹配
DIRECT:0
OSPF:10
IS-IS:15
STATIC:60
RTP:100
OSPF ASE:150
OSPF NSSA:150
IBGP:256
EBGP:256
3.相同路由协议的情况下,选取metric值最小的的最优先匹配。每种协议metric值定义的都不相同,静态路由和路由优先级有关,这个是人为指定的,RIP协议和跳数有关,跳数越小越优先,OSPF协议和带宽有关,带宽最大最优先。metric是用来判定链路质量优劣的。
4.如果以上都没有路由可以匹配得上,就匹配默认路由。

3.静态路由的优点和缺点

优点:配置灵活,管理员手工配置,节省链路开销
缺点:当拓扑发生改变时,需要管理员去每台路由器上修改路由配置

4.默认路由是什么;它的使用场合

默认路由是静态路由的一种特殊形式,它属于静态路由中的一种,使用它是有条件的,只能在末梢网络中使用
静态路由协议只能小规模的企业网络,大型企业网络用的是动态路由协议
建议五条以内的外部路由用静态路由协议,五条以上的用动态路由协议

5.浮动路由的作用

浮动路由指的是配置两条静态路由,默认选取链路质量优(带宽大的)作为主路径,当路径出现故障时,由带宽较小的备份路由顶替,保持网络不中断。

二级目录 实验拓扑图

在这里插入图片描述
这个实验是通过静态路由把两个单臂路由连接起来实现全网互通,并设置浮动路由防止网络中断。

三级目录 实验结果

 ****sysname SW1****

vlan batch 10 20

interface MEth0/0/1

interface Ethernet0/0/1
port link-type access
port default vlan 10

interface Ethernet0/0/2
port link-type access
port default vlan 20

interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 20

sysname SW2

vlan batch 30 40
interface MEth0/0/1

interface Ethernet0/0/1
port link-type access
port default vlan 30

interface Ethernet0/0/2
port link-type access
port default vlan 40

sysname R1

interface Ethernet0/0/0
ip address 21.1.1.1 255.255.255.0

interface GigabitEthernet0/0/0.1
vlan-type dot1q 10
ip address 192.168.10.1 255.255.255.0

interface GigabitEthernet0/0/0.2
vlan-type dot1q 20
ip address 192.168.20.1 255.255.255.0

interface GigabitEthernet0/0/1
shutdown
ip address 12.1.1.1 255.255.255.0

ip route-static 0.0.0.0 0.0.0.0 12.1.1.2
ip route-static 0.0.0.0 0.0.0.0 21.1.1.2
ip route-static 192.168.10.0 255.255.255.0 21.1.1.2

sysname R2

interface Ethernet0/0/0
ip address 21.1.1.2 255.255.255.0

interface GigabitEthernet0/0/0
ip address 12.1.1.2 255.255.255.0

interface GigabitEthernet0/0/1
ip address 23.1.1.2 255.255.255.0

ip route-static 12.1.1.0 255.255.255.0 12.1.1.1
ip route-static 192.168.10.0 255.255.255.0 12.1.1.1
ip route-static 192.168.10.0 255.255.255.0 21.1.1.1
ip route-static 192.168.20.0 255.255.255.0 12.1.1.1
ip route-static 192.168.20.0 255.255.255.0 21.1.1.1
ip route-static 192.168.30.0 255.255.255.0 23.1.1.3
ip route-static 192.168.40.0 255.255.255.0 23.1.1.3

sysname R3

interface GigabitEthernet0/0/0
ip address 23.1.1.3 255.255.255.0

interface GigabitEthernet0/0/1.1
vlan-type dot1q 30
ip address 192.168.30.1 255.255.255.0

interface GigabitEthernet0/0/1.2
vlan-type dot1q 40
ip address 192.168.40.1 255.255.255.0

ip route-static 0.0.0.0 0.0.0.0 23.1.1.2


本文链接: http://www.dtmao.cc/news_show_250336.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?