Synchnorized php qt file webview menu null Plupload Movejs angularjs版本 vue安装 后台管理系统模板 多店版微信商城 纯html网页模板 centos查看php版本 oracle显示所有数据库 input边框颜色 mysql获取当前时间戳 bootstrap居中对齐 centos定时任务 python输出函数 linux配置python环境 java正则表达式详解 java实现多线程 java实例变量 java入门基础 java时间转时间戳 linux安装教程 linux中sudo 蓝牙运动耳机排行榜 广告代码 超级兔子ie修复专家 网络电视软件下载 mounted vue上传文件 java语言程序设计 listpreference 8元秒电脑 lol语音包 win10有哪些版本
当前位置: 首页 > 学习教程  > 编程语言

HSRP(2020.7.17)

2020/7/24 10:27:47 文章标签:

HSRP(热备份路由协议)

先在下图中配置通网

在这里插入图片描述
第一步:规划有哪些网段(三层交换机和路路由器是隔离网段的)

4个网段

在这里插入图片描述
代码

接入层交换机
Switch 2:

Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport access vlan 40
Switch(config-if)#exit
Switch(config)#interface range f0/2-3
Switch(config-if-range)#switchport mode trunk 

核心层

Switch0:

Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport trunk en do
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#interface vlan 40
Switch(config-if)#ip address 192.168.40.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing

Swtch13:

Switch(config)#vlan 40
Switch(config-vlan)#exit
Switch(config)#int
Switch(config)#interface f0/1
Switch(config-if)#switchport trunk en do
Switch(config-if)#switchport mode trunk 
Switch(config)#interface vlan 40
Switch(config-if)#ip address 192.168.40.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip routing

Swtch0 switch13 (三层交换机端口配置IP地址)方法

Switch0

Switch(config)#interface f0/2
Switch(config-if)#ip address 192.168.20.1 255.255.255.0	
Switch(config-if)#no switchport //将交换机二层接口转换成路由器的类型的接口
Switch(config-if)#ip address 192.168.20.1 255.255.255.0

Switch13

Switch(config)#interface f0/2
Switch(config-if)#no switchport 
Switch(config-if)#ip address 192.168.30.1 255.255.255.0

路由器的端口配置IP地址

Router0:

Router(config)#interface g0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.20.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.30.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface g0/2
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.10.1 255.255.255.0

服务器IP地址和网关配置

在这里插入图片描述

实现全网络互通:路由协议

在这里插入图片描述
实现RIP路由协议的配置
在这里插入图片描述
代码

Switch0:

Switch#show ip route
C 192.168.20.0/24 is directly connected, FastEthernet0/2
C 192.168.40.0/24 is directly connected, Vlan40
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#router rip 
Switch(config-router)#network 192.168.20.0
Switch(config-router)#network 192.168.40.0

Switch13:

Switch#show ip route
C 192.168.30.0/24 is directly connected, FastEthernet0/2
C 192.168.40.0/24 is directly connected, Vlan40
Switch(config)#router rip 
Switch(config-router)#network 192.168.30.0
Switch(config-router)#network 192.168.40.0

Router

Router#show ip route

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/2
L 192.168.10.1/32 is directly connected, GigabitEthernet0/2
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, GigabitEthernet0/0
L 192.168.20.2/32 is directly connected, GigabitEthernet0/0
192.168.30.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.30.0/24 is directly connected, GigabitEthernet0/1
L 192.168.30.2/32 is directly connected, GigabitEthernet0/1

Router(config)#router rip 
Router(config-router)#network 192.168.10.0
Router(config-router)#network 192.168.20.0
Router(config-router)#network 192.168.30.0

测试:

判断数据走的哪条线路

tracert 192.168.10.10

在这里插入图片描述
问题:
PC0电脑要出去访问服务器
当左连或者右连线路或都三层交换机出现故障了
我们要去手工去修改网关(手动改网关是不太明智选择)

所以CISCO就自已开发了一个hsrp自动完成这个工作
实现不改网关情况坏了一台设备会自动启用别外一台设备

所以现在需要用到一种技术:HSRP

HSRP

(HSRP是实现设备的硬件备份)

HSRP:热备份路由协议
背景:不修改计算机的网关的前提下实现设备的硬件备份

HSRP:三层技术
HSRP检测范围:断设备 二层交换机与三层交换机之间的链路

如果要检测上线链路,需要启用端口跟踪功能

Interface vlan 10
Standby 1 track f0/1

每个交换机的优先级默认是100,优先越大越优先成为主设备(active)
Interface vlan 10
Standby 1 priority 120
Standby 1 preempt(抢占)

抢占:a维护,就会切换到b
当a修好以后,不会继续走b,会被a抢占

HSRP 是思科私有技术
VRRP是公有技术

例子:

(两台核心交换机上配置)

在这里插入图片描述
要使得VLAN 10 和VLAN30 数据包走左边的交换机
VLAN 20 和VLAN 40 数据包走右边的交换机

在这里插入图片描述

代码:

Switch0

Switch(config)#interface vlan 10
Switch(config-if)#standby 1(不同VLAN使用不同的主号) ip 192.168.10.254(备份)
Switch(config-if)#standby 1 priority 200(设置更高的优先级,使其成为VLAN 10 的主设备)
Switch(config-if)#standby 1 preempt(抢占)
Switch(config-if)#standby 1 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#standby 2(不同VLAN使用不同的主号) ip 192.168.20.254(备份)
Switch(config-if)#standby 2 preempt(抢占)
Switch(config-if)#standby 2 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#standby 3(不同VLAN使用不同的主号) ip 192.168.30.254(备份)
Switch(config-if)#standby 3 priority 200(设置更高的优先级,使其成为VLAN 30 的主设备)
Switch(config-if)#standby 3 preempt(抢占)
Switch(config-if)#standby 3 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 40
Switch(config-if)#standby 4(不同VLAN使用不同的主号) ip 192.168.40.254(备份)
Switch(config-if)#standby 4 preempt(抢占)
Switch(config-if)#standby 4 track f0/2(端口跟踪)

Switch13

Switch(config)#interface vlan 10
Switch(config-if)#standby 1(不同VLAN使用不同的主号) ip 192.168.10.254(备份)
Switch(config-if)#standby 1 preempt(抢占)
Switch(config-if)#standby 1 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 20
Switch(config-if)#standby 2(不同VLAN使用不同的主号) ip 192.168.20.254(备份)
Switch(config-if)#standby 2 priority 200(设置更高的优先级,使其成为VLAN 20 的主设备)
Switch(config-if)#standby 2 preempt(抢占)
Switch(config-if)#standby 2 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#standby 3(不同VLAN使用不同的主号) ip 192.168.30.254(备份)
Switch(config-if)#standby 3 preempt(抢占)
Switch(config-if)#standby 3 track f0/2(端口跟踪)
Switch(config-if)#exit
Switch(config)#interface vlan 40
Switch(config-if)#standby 4(不同VLAN使用不同的主号) ip 192.168.40.254(备份)
Switch(config-if)#standby 4 priority 200(设置更高的优先级,使其成为VLAN 40 的主设备)
Switch(config-if)#standby 4 preempt(抢占)
Switch(config-if)#standby 4 track f0/2(端口跟踪)

这样两台交换机都虚拟一个地址192.168.40.254(这个地址就作为VLAN 10的网关)

Switch 0
在这里插入图片描述

Switch 13
在这里插入图片描述
再tracert IP地址

在这里插入图片描述
寻找路径
可以发现
走的是右边
证明网关设置哪边走哪边
到达路由器以后,随机给出一个接口IP。


本文链接: http://www.dtmao.cc/news_show_50272.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?