ActiveMQ CGLib动态代理 webstorm汉化包 人脸识别 drupal jq解析json jq获取元素宽度 db2从入门到精通 idea大小写转换快捷键 linux 获取系统时间 android调试工具 java清空数组 ubuntu显示隐藏文件夹 python3教程 python指数函数 python中len函数 python下载安装教程 python读取数据库 java入门新手教程 java怎么安装 java怎么配置环境变量 java输出当前时间 java重命名 linux系统教程 东方头条邀请码 疯狂java js保留两位小数 mysql导出数据 抠图软件免费版 renderto ftp客户端软件 bootskin excel后缀 淘新闻下载 python去重 mysql密码重置 数码管字体 csshover 迅雷去广告 网页广告
当前位置: 首页 > 学习教程  > 编程语言

思科PPPOE配置方法

2020/7/24 11:21:12 文章标签: 测试文章如有侵权请发送至邮箱809451989@qq.com投诉后文章立即删除

PPPoE是在以太网上实现PPP封装的协议,它利用以太网将大量主机接入网络,通过一个远端接入设备连入因特网,并对接入的每一个主机实现控制、计费等功能。
与传统的接入方式相比,pppoe具有较高的性能价格比,它在包括小区组网建设等一系列应用中被广泛采用,目前流行的宽带接入方式ADSL 就使用了pppoe协议。

PPPoE的五种报文
PADI —发现初始化报文
PADO —发现提供报文
PADR —发现请求报文
PADS —发现会话确认报文
PADT —发现终止报文

需要注意调整MTU
IP MTU 1492
TCP MSS 1452

配置:
server端
ip local pool cisco 61.128.1.1 //定义给客户分配的地址池范围
bba-group pppoe xxxx //定义一个pppoe组
virtual-template 1 //定义一个模板
interface Ethernet0/0
no ip address
pppoe enable group xxxx //调用组
interface Virtual-Template1 //调用模板
ip address 61.128.1.10 255.255.255.0
ip mtu 1492 //设置MTU
peer default ip address pool cisco //指定从哪个池给客户分地址

客户端
interface Ethernet0/0
no ip address
pppoe enable group global // 使能pppoe
pppoe-client dial-pool-number 6 //定义拨号的池

interface Dialer1 //创建拨号接口
mtu 1492 //设置MTU
ip address negotiated //跟server端协商地址
encapsulation ppp //指定PPP封装
dialer pool 6 //调用拨号池

认证:
server
username Cisco password 0 xxxx
ppp authentication chap callin
client
ppp chap hostname Cisco
ppp chap password xxxx

NAT应该怎么做?
outside接口应该写在dialer接口上
interface dialer 1
ip nat outside
ip nat inside source list 2 interface dialer 1 overload

如何从运营商获取一条默认路由?
interface dialer 1
ppp ipcp route default


本文链接: http://www.dtmao.cc/news_show_50409.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?