Synchnorized Apache 百度搜索优化 asynchronous deployment scope get vue教程入门 鼠标进入和离开事件 js字符串排序 Navicat oracle分析函数 docker保存镜像 linux查询文件内容 mysql学习 mysql事务 python操作mysql random函数用法 python写入文件 java日期类 java实例方法 linux服务器 网页游戏开发入门 wps2011 圣剑世界 bat脚本 一键换系统 unix系统下载 陌陌电脑直播设置教程 medcalc 数组求和 ios删除描述文件 ps出血 拼多多商家下载 网红照片男 网络驱动 现代操作系统 变声器电脑版 sqlprompt 勇敢者的游戏3
当前位置: 首页 > 学习教程  > 编程语言

eNSP:OSPF基本配置(单区域配置,多区域配置,DRBDR选举)

2020/12/28 18:40:17 文章标签:

这里写目录标题DR和BDR选举规则根据router-id选举根据优先级选举OSPF区域骨干区域单区域配置单区域含义结构图配置多区域配置多区域含义结构图配置DR和BDR DR(Designated Router) 指定路由器 BDR(Backup Designated Router) 备份指…

这里写目录标题

  • DR和BDR
    • 选举规则
      • 根据router-id选举
      • 根据优先级选举
  • OSPF区域
    • 骨干区域
    • 单区域配置
      • 单区域含义
      • 结构图
      • 配置
    • 多区域配置
      • 多区域含义
      • 结构图
      • 配置

DR和BDR

DR(Designated Router) 指定路由器
BDR(Backup Designated Router) 备份指定路由器

DR和BDR可以减少邻接关系的数量,从而减少链路状态信息以及路由信息的交换次数,这样可以节省带宽,降低对路由器处理能力的压力。一个既不是DR也不是BDR的路由器只与DR和BDR形成邻接关系并交换链路状态信息以及路由信息,这样就大大减少了大型广播型网络和NBMA网络中的邻接关系数量。
BDR在DR发生故障时接管业务,一个广播网络上所有路由器都必须同BDR建立邻接关系。

不使用DR&BDR建立邻接关系
在这里插入图片描述
不使用DR&BDR我们需要建立10个邻接关系

使用DR&BDR建立邻接关系
在这里插入图片描述
使用DR&BDR我们只需要建立7个邻接关系,这种差距会随着路由器数量的增加变得更加明显

选举规则

路由器会根据参与选举的每个接口的优先级进行DR选举,优先级取值范围为0-255,值越高越优先。缺省情况下,接口优先级为1。如果一个接口优先级为0,那么该接口将不会参与DR或者BDR的选举。如果优先级相同时,则比较Router ID,值越大越优先被选举为DR。

根据router-id选举

在这里插入图片描述

在每个路由器上配置OSPF

R1

[Huawei]ospf router-id 1.1.1.1
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255

R2

[Huawei]ospf router-id 2.2.2.2
[Huawei-ospf-1]area 0
[Huawei-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255

保存配置并重启路由器,在R1和R2中执行保存命令

<Huawei>save
  The current configuration will be written to the device. 
  Are you sure to continue? (y/n)[n]:y
  It will take several minutes to save configuration file, please wait.......
  Configuration file had been saved successfully
  Note: The configuration file will take effect after being activated

重启后查看DR和BDR(先等待R1和R2建立完邻接关系)

[Huawei]display ospf peer 

在这里插入图片描述
因为R1和R2接口的优先级相同,所以根据router-id来选举,因为R2的router-id大于R1的router-id,所以R2被选举为DR

根据优先级选举

还是借助上面的配置,因为R2的router-id大于R1的router-id,所以R2的接口被选举为DR,现在我们改变一下两个路由器接口的优先级,再重新选举DR&BDR

配置接口优先级

R1

将路由器R1的g0/0/0接口的优先级改为20

[Huawei]interface GigabitEthernet 0/0/0
[Huawei-GigabitEthernet0/0/0]ospf dr-priority 20

R2

将路由器R2的g0/0/1接口的优先级改为10

[Huawei]interface GigabitEthernet 0/0/1
[Huawei-GigabitEthernet0/0/1]ospf dr-priority 10

保存两个路由器的配置,然后重启

<Huawei>save
  The current configuration will be written to the device. 
  Are you sure to continue? (y/n)[n]:y
  It will take several minutes to save configuration file, please wait.......
  Configuration file had been saved successfully
  Note: The configuration file will take effect after being activated

重启后查看DR&BDR(先等待R1和R2建立完邻接关系)

[Huawei]display ospf peer

在这里插入图片描述虽然R2的router-id大于R1的router-id,但是路由器会先根据接口的优先级进行选举,因为接口g0/0/0的优先级比接口g0/0/1的优先级高(值越大优先级越高),所以R1的g0/0/0接口被选举为DR

OSPF区域

骨干区域

当网络中包含多个区域时,OSPF 协议有特殊的规定,即其中必须有一个 Area 0,通常也叫做骨干区域(Backbone Area),当设计 OSPF 网络时,一个很好的方法就是从骨干区域开始,然后再扩展到其他区域。骨干区域在所有其他区域的中心,即所有区域都必须与骨干区域物理或逻辑上相连,这种设计思想的原因是 OSPF 协议要把所有区域的路由信息引入骨干区,然后再依次将路由信息从骨干区域分发到其它区域中。OSPF 中划分区域的目的就是在于控制链路状态信息LSA 泛洪的范围、减小链路状态数据库LSDB的大小、改善网络的可扩展性、达到快速地收敛。

也就是说,非骨干区域之间不能直接进行通信,必须先将信息发送到区域0,然后再通过区域0发送到目标区域,如下图:如果区域1想要和区域2进行通信,必须先将信息发送到区域0,然后再通过区域0转发到区域2,从而实现两者之间的通信

在这里插入图片描述
但是如果我们把区域0的位置调换一下,区域1访问区域2,区域1将信息发送给区域0,区域0却无法将信息转发给区域2,所以此时区域1和区域2是无法进行通信的,所以在设置区域时,一定要把区域0放到中心的位置,保证每个区域都能和区域0相连

在这里插入图片描述

单区域配置

单区域含义

整个链路中,所有开启了OSPF协议的路由器都处在同一区域中

结构图

在这里插入图片描述
实现目标:在路由器R1,R2,R3中使用OSPF协议实现位于不同网段中的主机PC1,PC2,PC3之间能够互相访问

配置

路由器R1

[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[R1-GigabitEthernet0/0/0]quit 
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 10.0.12.1 24
[R1-GigabitEthernet0/0/1]quit
[R1]ospf router-id 1.1.1.1
[R1-ospf-1]area 1
[R1-ospf-1-area-0.0.0.1]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.1]network 10.0.12.0 0.0.0.255

router-id 唯一标识开启了OSPF协议的路由器

在使用 network 命令通告路由信息时,格式为:

network 通告的IP地址网段 IP地址反子网掩码

路由器R2

[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 10.0.12.2 24
[R2-GigabitEthernet0/0/1]qu
[R2]interface GigabitEthernet 0/0/2
[R2-GigabitEthernet0/0/2]ip address 10.0.23.1 24
[R2-GigabitEthernet0/0/2]qu
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.2.1 24
[R2-GigabitEthernet0/0/0]qu
[R2]ospf router-id 2.2.2.2
[R2-ospf-1]area 1
[R2-ospf-1-area-0.0.0.1]network 192.168.2.0 0.0.0.255
[R2-ospf-1-area-0.0.0.1]network 10.0.12.0 0.0.0.255
[R2-ospf-1-area-0.0.0.1]network 10.0.23.0 0.0.0.255

路由器R3

[R3]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ip address 10.0.23.2 24
[R3-GigabitEthernet0/0/1]qu
[R3]interface GigabitEthernet 0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[R3-GigabitEthernet0/0/0]qu
[R3]ospf router-id 3.3.3.3
[R3-ospf-1]area 1
[R3-ospf-1-area-0.0.0.1]network 192.168.3.0 0.0.0.255
[R3-ospf-1-area-0.0.0.1]network 10.0.23.0 0.0.0.255

查看路由表信息(以R1为例)

执行命令:display ip routing-table
在这里插入图片描述
PC配置
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

访问测试(以PC1为例)
在这里插入图片描述

多区域配置

多区域含义

整个链路中,所有开启了OSPF协议的路由器分别处在多个不同的区域中

结构图

在这里插入图片描述
实现目标:在路由器R1,R2,R3中使用OSPF协议实现位于不同网段中的主机PC4,PC5,PC6之间能够互相访问

配置

R1

[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[R1-GigabitEthernet0/0/0]qu
[R1]interface GigabitEthernet 0/0/1
[R1-GigabitEthernet0/0/1]ip address 10.0.12.1 24
[R1-GigabitEthernet0/0/1]qu
[R1]ospf router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255

R2

因为R2同时处于区域0和区域1,所以称R2为"边界路由",边界路由的配置规则是:接口处于哪个区域就在哪个区域进行通告,处于区域之间的接口,放在哪个区域都可以,但最好放在区域0当中,也就是能放到骨干区域的就放到骨干区域

[R2]interface GigabitEthernet 0/0/1
[R2-GigabitEthernet0/0/1]ip address 10.0.12.2 24
[R2-GigabitEthernet0/0/1]qu
[R2]interface GigabitEthernet 0/0/2
[R2-GigabitEthernet0/0/2]ip address 10.0.23.1 24
[R2-GigabitEthernet0/0/2]qu
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address  192.168.2.1 24
[R2-GigabitEthernet0/0/0]qu
[R2]ospf router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]network 10.0.12.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]network 192.168.2.0 0.0.0.255
[R2-ospf-1-area-0.0.0.0]qu
[R2-ospf-1]area 1
[R2-ospf-1-area-0.0.0.1]network 10.0.23.0 0.0.0.255

R3

[R3]interface GigabitEthernet 0/0/1
[R3-GigabitEthernet0/0/1]ip address 10.0.23.2 24
[R3-GigabitEthernet0/0/1]qu
[R3]interface GigabitEthernet 0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.3.1 24
[R3-GigabitEthernet0/0/0]qu
[R3]ospf router-id 3.3.3.3
[R3-ospf-1]area 1
[R3-ospf-1-area-0.0.0.1]network 192.168.3.0 0.0.0.255
[R3-ospf-1-area-0.0.0.1]network 10.0.23.0 0.0.0.255

查看路由表信息(以R3为例)

执行命令display ip routing-table
在这里插入图片描述
PC配置
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
访问测试(以PC6为例)
在这里插入图片描述


本文链接: http://www.dtmao.cc/news_show_550063.shtml

附件下载

相关教程

    暂无相关的数据...

共有条评论 网友评论

验证码: 看不清楚?